Information wants to be free...

Fujitsu FKB8530 Keyboard Repair

I got hold of a strange looking modular keyboard, the Fujitsu FKB8530, which I wanted to refurbish due to its unique construction. Unfortunately I discovered that it had sustained some kind of liquid damage, which in turn had caused corrosion on the membrane. The result was that some of the keys did not work. Measurements showed that the resistance had gotten too high between some of the points on one of the traces on the membrane.

I was able to repair this by gently scraping of the top layer on the membrane trace with a knife, then applying conductive silver paint (Loctite 3863 Circuit +) on top. I used regular Scotch tape to mask off the relevant area:

Silver paint applied


The keyboard after re-assembly:

Re-assembled keyboard


Topic: Repair, by Kjetil @ 22/09-2021, Article Link

Tandon TM9362 Data Recovery

I have a Tandon TM9362 hardcard. Such hardcards are notorious for failing, a common problem is that the heads and other mechanical parts get stuck over time. Despite this I managed to fully recover the data from it. The actual hard drive on the card is a Tandon TM362, which is a 21MB MFM drive.

Tandon TM9362 and Bike Oil


The shaft of the motor controlling the heads on these drives are actually accessible, which makes things easer. I managed to turn the shaft manually with my fingers to loosen it. Afterwards I applied 2 drops of "Bike Oil", which is similar to bearing oil, into the motor through the shaft and wiggled it some more. The card was then connected to a 486-class PC. Still, even with this oil applied it would not always power up on startup, but some more wiggling and power cycling made it spin up in the end.

This card contains it's own BIOS routines for accessing the disk, so I removed the existing hard drive on the PC to prevent any interference. It booted up with MS-DOS 3.20 and timestamps from 1990, so it could have been over 30 years since it was last accessed. I think MS-DOS 3.20 has issues with newer 1.44M floppy disks, so I booted DOS 5.0 from a floppy instead, still with the hardcard connected of course.

This PC has a 3Com 3C509 Ethernet card, so I loaded the Crynwr Packet Drivers for this and configured mTCP for TCP/IP networking. I setup the mTCP "ftpsrv" FTP server to host ALL files from the C: drive and used "ncftpget" from a Linux box to recursively download everything.

An additional cool but not really necessary step is to get those files onto a virtual disk image that can be loaded in QEMU. This particular hardcard has a CHS configuration of 615 cylinders, 4 heads and 17 sectors (per cylinder). Multiplying this with the standard sector size of 512 gives 41820, so a blank disk image can be made by:

dd if=/dev/zero of=tandon.img bs=512 count=41820
          


Importantly, in order for QEMU to properly forward the same CHS settings into the emulation, it needs to be specified on startup like so:

qemu-system-i386 -drive file=tandon.img,format=raw,if=none,id=dr0 -device drive=dr0,driver=ide-hd,cyls=615,heads=4,secs=17 -boot c
          


So actually get the files over I booted QEMU with the virtual disk image and another copy of a MS-DOS 3.20 floppy boot disk image that I found online. From the emulated DOS i ran the DOS "fdisk" and "format c: /s" to format the virtual disk in a compatible manner. Then I ran the Linux "fdisk" on the image and noticed the FAT partition was placed on sector 17 and onwards. Multiplying this by 512 gives 8704, so the partition on the virtual disk image can be loopback mounted like so:

sudo mount -o loop,offset=8704 tandon.img /tmp/tandon
          


Afterwards the recovered files can just be copied into the mounted loopback drive. The result is a bootable (in QEMU) virtual disk image with the correct MBR and VBR.

Topic: Repair, by Kjetil @ 07/08-2021, Article Link

Retrobright Experiment

I finally got around to trying the Retrobright technique to remove yellowing. You need UV light, so doing this in Norway is a bit tricky because the weather is quite unpredictable and we do not have a lot of sun. Also, the Hydrogen peroxide (H2O2) needed is expensive and only comes in maximum 6% solution. I have an old computer mouse which was very yellowed and a perfect candidate for this experiment due to its small size.

There are several different methods and recipes to use for Retrobrighting, but I chose the plastic wrap method and using only H2O2 and corn starch. I put the 6% H2O2 into a cup and gradually added corn starch until I thought the mixture was thick enough. Afterwards I poured the mixture on the plastic wrap, put the yellow part of the mouse on the mixture and wrapped it together.

It was supposed to be a sunny day so I put the wrapped mouse outside at 08:30 in the morning, and then retrieved it at 18:30 in the evening, so it got around 10 hours of sunlight in total. All in all I was quite satisfied with the result.

Here is a picture showing the before and after and the different stages, you may notice the small bubbles appearing which is a sign the process is working.

Retrobright steps of Brother Mouse


Topic: Repair, by Kjetil @ 19/06-2021, Article Link

Gould 1604 Oscilloscope Repair

I have gotten hold of a Gould DRO 1604 oscilloscope from 1989. It would power on, but the display was severely distorted and looked like this:

Gould 1604 Before


I cracked open the case and first of all removed a leaking battery, which is not related to the display problem, but important to fix as soon as possible:

Gould 1604 Battery


Luckily there is a service manual available for this particular oscilloscope, which helps a lot in giving troubleshooting tips and places to measure. I first discovered that pin 4 of U803 (the Y DAC chip) had -3.3V but the service manual said it should be either -2.8V or -4.2V, depending on the "dot joining" state. This led me to Q811 (a MOSFET controlling the "dot join") which had a strange voltage of -3.41V on it's gate, where it should have been either 0V or -5V. According to the circuit diagram the gate of Q811 is pulled by a resistor connected to the -12V power rail.

I measured the -12V rail, and this was only around -11V which is too low. This rail is controlled by a LM377T linear regulator, which is adjusted by a set of resistors and capacitors. I checked the three associated resistors R1, R2 and R16 and they all had the correct values. However, the two capacitors C15 and C16 had correct capacitance but horrible ESR value of 23 and 33 ohms.

Here are the two bad capacitors, with blue casing:

Gould 1604 Old Capacitors


Which i promptly replaced with new ones:

Gould 1604 New Capacitors


This fixed the -12V power rail, which now measures around actual -12 volts, and the display is now working:

Gould 1604 After


Topic: Repair, by Kjetil @ 04/12-2020, Article Link

Amitech Amiga Mouse Repair

I have an Amiga mouse that behaved so poorly that it was unusable. The symptom was that movement was barely detected, if at all at some times. After digging around on the Internet I found that one possible cause is the IR emitter and IR photo-transistors that are used to generate the quadrature encoder pulses.

I ordered replacements from my local dealer, specifically:
* OP 750A - IR phototransistor 850 nm 30 V Side Looking, Optek

IR phototransistors


* IRL 81A - IR emitter 860nm 100mA 1.3V THT, Osram Opto Semiconductors

IR emitters


And soldered on these replacements:

Amitech mouse replacements


This is indeed what was causing the problems and the mouse is now working again:

Amitech Denmark Logo


Topic: Repair, by Kjetil @ 03/10-2020, Article Link

Amiga 500 Capacitor Replacement

I recently replaced all the electrolytic capacitors on my Commodore Amiga 500. This was originally for troubleshooting and diagnostics purposes, but sometimes it is a good idea anyway because electrolytic capacitors are prone to drying up and become worse over time. I understand that this varies a lot between manufacturers and production batches, so it's not always the case. As for the Amiga 500, there seems to be some dispute.

Anyway, in this process I had to come up with a easy way to track the work while soldering. So I made this "map" with all the capacitors and their values. It might be helpful to others later:

Amiga 500 Capacitor Locations


Note that this is a Amiga 500 revision 5 board, so others might be different.

Topic: Repair, by Kjetil @ 01/05-2020, Article Link

NCR System 3330 Dallas RTC Mod

The Dallas DS12887 RTC inside my NCR System 3330 PC had died a long time ago. Unfortunately, this made the machine unbootable from the hard drive, since it would forget the hard drive settings on each restart. Instead of finding a replacement, like for the Commodore PC 30-III, I opted for the external battery modification instead. I got this working with just two regular AA 1.5V alkaline batteries, a huge success!

The initial error on every startup was as follows:

NCR Battery Power Lost


Fortunately, the Dallas RTC is a in a socket on this machine, easily extracted:

NCR Dallas RTC Extracted


To perform the mod, two sections of the case needs to be opened, which I did with a Dremel tool:

NCR Dallas RTC Dremeled


Afterwards, it's possible to solder on leads for a new battery:

NCR Dallas RTC with new battery leads


I installed a new 2xAA battery holder inside the case, connected to the RTC:

NCR Dallas RTC external battery


The machine is now working again, settings can be saved to CMOS and booting from hard drive is possible:

NCR Powered On


Topic: Repair, by Kjetil @ 14/03-2020, Article Link

Commodore PC 30-III Repair

The Commodore PC 30-III is a AT-class 286 clone PC running at 12MHz with 1MB of RAM. My first and initial problem was the battery failure upon booting:

Commodore PC 30-III Battery Failure


For some reason, It was not possible to get past this error and continue booting anyway, so a replacement was needed. I got hold of a Glitch Works GW-12887-1 which can replace the original Dallas 1287 RTC in this machine:

Commodore PC 30-III Dallas DS1287 RTC


This is unfortunately soldered directly to the motherboard. But I cut a socket and soldered that one on instead:

Commodore PC 30-III U201 Socket Replacement


In which the replacement fits nicely:

Commodore PC 30-III GW-12887-1


This got the machine booting properly. But after a while of playing around with Compact Flash disk replacements, magic smoke suddenly appeared. Which became my second problem. I located the source; a burned ceramic capacitor:

Commodore PC 30-III Burned Ceramic Capacitor


From what I could find out online, these capacitors can fail if cracks appear in them, and moisture gets in over time. So that's most likely what happened to this 30 year old component. I got a replacement and removed the bad one, which disintegrated almost by itself:

Commodore PC 30-III Capacitor Replacement


The brand new ceramic capacitor in place:

Commodore PC 30-III New Capacitor


The machine is now up and running again:

Commodore PC 30-III Front


Topic: Repair, by Kjetil @ 08/12-2019, Article Link

Commodore 1541-II Floppy Drive Repair

I was able to repair my Commodore 1541-II floppy drive, which is typically used together with the Commodore 64.

The first problem was that I do not have the original (external) power supply, but fortunately it uses fairly standard +5V and +12V voltages, which are also used by most PC hardware. So I made an adapter from a 4-pin molex to a 4-pin DIN connector:

Commodore 1541-II Power Adapter

The pinout of the DIN connector can be found here among other places.

When powering up the drive for the first time, it would keep the drive motor running constantly, which is apparently a known problem. Some other people online said this could be caused by a faulty PSU or bad ROM chip...

When I attempted to continue troubleshooting the next day, the situation had worsened. Now the power LED on the drive would flash a little on power on and slowly fade away. Symptoms of a short circuit or something perhaps...

With no idea on what to do about this, I decided to try to replace the electrolytic capacitors, which people often do on restoration/repair projects.

There are only three of them on the main board, all 10uF and 25V, located here:

Commodore 1541-II Capacitor Locations


Old and new replacements:

Commodore 1541-II Capacitor Replacement


To my surprise, this actually worked, and the drive is now working:

Commodore 1541-II Working


I have a theory: Two of those capacitors I changed are between the incoming 12V/5V and ground, acting as "decouping/bypass" to filter out noise. If there happened to be a short circuit or weakened resistance in the capacitors, that would explain parts of the symptoms at least.

Topic: Repair, by Kjetil @ 26/10-2019, Article Link